WordPress Gutenberg : TypeError: Cannot read property ‘show_ui’ of undefined

Par défaut

Ca fait plusieurs semaines que je suis passé sur WordPress pour mon blog perso, la chose qui m’a fait quitter dotclear fut l’outil de d’écriture de billet Gutenberg que j’ai pu tester ici. C’est à des années lumières de l’éditeur de texte que j’utilisais auparavant. Seulement voilà, une fois les joies de la migration passées, me voici à activer Gutenberg et pouf, ça plante méchamment : impossible d’afficher quoi que ce soit.

Voici ce qui s’affiche lorsque l’on a une erreur dans gutenberg

J’ai passé plusieurs jours à chercher d’où pouvait venir le problème. A priori les causes sont multiples mais dans mon cas, c’était lié à un problème avec les permalinks (permaliens en français) customisés.

On peut trouver le détail dans ce topic de github. Pour résumer, un des contributeur explique que c’est lié à la gestion des query-strings sur les permaliens. Et magie du libre, il a fourni un morceau de code pour corriger le problème. Mais on en fait quoi de ce code ensuite ? Et bien il faut créer un plug-in pour pouvoir activer / désactiver le correctif directement depuis la console d’administration de wordpress. (en attendant une correction de gutenberg j’imagine)

Je joins en copie le zip du plug-in que j’ai fait à partir du code trouvé sur le ticket de github. Il ne reste plus qu’à aller dans l’interface admin de WordPress et d’ajouter le plug-in en le téléversant.

Evidement, il est à prendre tel qu’il est et il n’y pas de support dessus 🙂

Laisser un commentaire

Votre adresse de messagerie ne sera pas publiée. Les champs obligatoires sont indiqués avec *

What is 3 + 12 ?
Please leave these two fields as-is:
IMPORTANT! Pour que ça marche, il faut répondre à la question (Comme ça je sais que ce n\'est pas un bot qui poste) :-)